#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)interface GigabitEthernet1.*(?=(?:(?!interface GigabitEthernet1)[\w\W])*switchport mode access)"
Local $sString = "interface GigabitEthernet1/0/1" & @CRLF & _
" description abc" & @CRLF & _
" bla" & @CRLF & _
" switchport mode access" & @CRLF & _
" xyz" & @CRLF & _
" abc" & @CRLF & _
"interface GigabitEthernet1/0/2" & @CRLF & _
"interface GigabitEthernet1/0/3" & @CRLF & _
" xyz" & @CRLF & _
" abc" & @CRLF & _
"interface GigabitEthernet1/0/4" & @CRLF & _
" description Test" & @CRLF & _
" switchport mode access" & @CRLF & _
" xyz" & @CRLF & _
" abc" & @CRLF & _
"interface GigabitEthernet1/0/5" & @CRLF & _
" description"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")