import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "interface GigabitEthernet1.*(?=(?:(?!interface GigabitEthernet1)[\\w\\W])*switchport mode access)";
final String string = "interface GigabitEthernet1/0/1\n"
+ " description abc\n"
+ " bla\n"
+ " switchport mode access\n"
+ " xyz\n"
+ " abc\n"
+ "interface GigabitEthernet1/0/2\n"
+ "interface GigabitEthernet1/0/3\n"
+ " xyz\n"
+ " abc\n"
+ "interface GigabitEthernet1/0/4\n"
+ " description Test\n"
+ " switchport mode access\n"
+ " xyz\n"
+ " abc\n"
+ "interface GigabitEthernet1/0/5\n"
+ " description";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}