package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-?\d+(\.\d+)?,?)+$`)
var str = `66,78.8,-89.8,0.0,3.14`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}