$re = '/^(-?\d+(\.\d+)?,?)+$/m';
$str = '66,78.8,-89.8,0.0,3.14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);