$re = '/^(?!www\.)[\+_a-z0-9-\'&=]+(\.[\+_a-z0-9-\']+)*@[a-z0-9-]+(\.[a-z0-9-]+)*(\.[a-z]{2,})$/m';
$str = 'www.test@example.com
abc.test@example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);