re = /^(?!www\.)[\+_a-z0-9-'&=]+(\.[\+_a-z0-9-']+)*@[a-z0-9-]+(\.[a-z0-9-]+)*(\.[a-z]{2,})$/m
str = 'www.test@example.com
abc.test@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end