import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*feedback[\\s_]report.*\\.xlsx";
final String string = "ZSS Project_JKIAL-SA_FEEDBACK_REPORT_Jan 29th 2015.xlsx\n"
+ "ZL-SA_feedback report_012844.xlsx\n"
+ "ASARanem-SA_Feedback Report_012844.xlsx\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}