import re
regex = re.compile(r".*feedback[\s_]report.*\.xlsx", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("ZSS Project_JKIAL-SA_FEEDBACK_REPORT_Jan 29th 2015.xlsx\n"
"ZL-SA_feedback report_012844.xlsx\n"
"ASARanem-SA_Feedback Report_012844.xlsx\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")