import re
regex = re.compile(r"^(?!(?:typescript|C#|python)$).+$", flags=re.MULTILINE)
test_str = ("typescript\n"
"C#\n"
"python\n"
"typescript 134\n"
"hello C#\n"
"python world\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")