re = /^(?!(?:typescript|C#|python)$).+$/m
str = 'typescript
C#
python
typescript 134
hello C#
python world
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end