#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)babel\.config\.(?:js(?:on)?|[cm]js)|\.babelrc(?:\.(?:js(?:on)?|[cm]js))?"
Local $sString = "babel.config.json " & @CRLF & _
"babel.config.js" & @CRLF & _
"babel.config.cjs" & @CRLF & _
"babel.config.mjs" & @CRLF & _
".babelrc.json" & @CRLF & _
".babelrc " & @CRLF & _
".babelrc.js" & @CRLF & _
".babelrc.cjs" & @CRLF & _
".babelrc.mjs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")