$re = '/babel\.config\.(?:js(?:on)?|[cm]js)|\.babelrc(?:\.(?:js(?:on)?|[cm]js))?/m';
$str = 'babel.config.json
babel.config.js
babel.config.cjs
babel.config.mjs
.babelrc.json
.babelrc
.babelrc.js
.babelrc.cjs
.babelrc.mjs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);