$re = '/^(?!(useRef|useEffect|useState))use[A-Z].*/m';
$str = 'useRef
useEffect
useState
useExample
useTest
useWhatever
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);