re = /^(?!(useRef|useEffect|useState))use[A-Z].*/m
str = 'useRef
useEffect
useState
useExample
useTest
useWhatever
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end