re = /^([A-Z]+)(?:,([A-Z]+))?(?:,([A-Z]+))?$/m
str = 'HELLO,LITTLE,WORLD
HELLO,WORLD
HELLO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end