re = /^(?![^:\s]+:)/m
str = '1 : A
2 : B
3 : C
1
2
3
1:A
11:A'
subst = 'Line:'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result