package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)[A-Z0-9-\/_]{7,}`)
var str = `Te poniższe bym chciał:
ZOC1050056
23639583
GL20/11878/17
20700246365_1
WR50/11349/17
PL201709120448
pl2017072600414
1054332/1133787
H201709201932-01
143392/DLS/17 KO/455/17
a to już false positives:
bardzodlugieslowo
niechcetegoo?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}