// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)[A-Z0-9-\/_]{7,}").unwrap();
let string = "Te poniższe bym chciał:
ZOC1050056
23639583
GL20/11878/17
20700246365_1
WR50/11349/17
PL201709120448
pl2017072600414
1054332/1133787
H201709201932-01
143392/DLS/17 KO/455/17
a to już false positives:
bardzodlugieslowo
niechcetegoo?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}