re = /\b\d+\)\h*\K.*?(?=\b\d+\)|$)/m
str = '1) some text 2) some more text 3) even more text, with commas and such 4) bye!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end