package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*\/)(\d+)$`)
var str = `https://example.com/items/html5-templates/654321`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}