$re = '/^(.*\/)(\d+)$/m';
$str = 'https://example.com/items/html5-templates/654321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);