#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)/Booking/Index.*"
Local $sString = "website.com/" & @CRLF & _
"website.com/Search/2343-5456-3423-5675" & @CRLF & _
"website.com/Availability?value=abc&value=123&step=1" & @CRLF & _
"website.com/Booking/Index/444-333-222-111" & @CRLF & _
"website.com/subdomain/" & @CRLF & _
"website.com" & @CRLF & _
"website.com?value=abc" & @CRLF & _
"website.com/Booking/Indexer" & @CRLF & _
"website.com/Booking/Index" & @CRLF & _
"website.com/Booking/Index?value=abc" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")