use strict;
my $str = 'website.com/
website.com/Search/2343-5456-3423-5675
website.com/Availability?value=abc&value=123&step=1
website.com/Booking/Index/444-333-222-111
website.com/subdomain/
website.com
website.com?value=abc
website.com/Booking/Indexer
website.com/Booking/Index
website.com/Booking/Index?value=abc
';
my $regex = qr`/Booking/Index.*`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}