package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(\d+)(?:-(\d+))?\]`)
var str = `[7-10], [20-30], [70]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}