$re = '/\[(\d+)(?:-(\d+))?\]/';
$str = '[7-10], [20-30], [70]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);