import re
regex = re.compile(r"<<<<<<<(?:\r?\n|.)*=======(?:\r?\n|.)*>>>>>>>.*\r?\n", flags=re.MULTILINE)
test_str = ("/**********************************\n"
"!&DOC-TECHNIQUE ! src/cmm/bacchus/b\n"
"!===============!==================\n"
"!&Fiche Du ! S.! Operateu\n"
"!__________________!___!___________\n"
"<<<<<<< HEAD\n"
"=======\n"
"! 2017-07-13! !Michèle ROY\n"
">>>>>>> 157443 - DRM-CIEL\n"
"!__________________________________\n"
"! \n"
"!__________________________________\n"
"&End \n"
"***********************************\n\n"
"{d-brokmini.i}\n"
"{bt-expciel.i }\n"
"{maquette.i }\n"
"{tabsoc.i }\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")