$re = '/^\p{L}\w{2,23}\p{Alnum}$/mU';
$str = '_notthis
nothis_
yes_123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);