package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^Dr\.?\s+`)
var str = `Dr.Mary Cross`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}