$re = '/^Dr\.?\s+/';
$str = 'Dr.Mary Cross';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;