using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\""[^""]*)\s*\"")|((?:\'[^']*)\s*\')|((?:\`[^`]*)\s*\`)|((?:\b|\s){1}const\s{1})|((?:\b|\s){1}function\s{1})|((?:\b|\s){1}let\s{1})|\s*";
string substitution = @"$1$2$3$4$5$6";
string input = @"function myFunction() {
let carName = ""Volvo"";
// code here CAN use carName
const test = 'string with ""quoted substring""'; let airlane = 'fly'
(""and another string th'' as' asd 'ere"")
labelForStrings: {
`t'is a ""string""`
}
}
/*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}