import Foundation
let pattern = #"((?:\"[^"]*)\s*\")|((?:\'[^']*)\s*\')|((?:\`[^`]*)\s*\`)|((?:\b|\s){1}const\s{1})|((?:\b|\s){1}function\s{1})|((?:\b|\s){1}let\s{1})|\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
function myFunction() {
let carName = "Volvo";
// code here CAN use carName
const test = 'string with "quoted substring"'; let airlane = 'fly'
("and another string th'' as' asd 'ere")
labelForStrings: {
`t'is a "string"`
}
}
/*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4$5$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)