import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/((www|m)\\.)?(youtube\\.com|youtu\\.be)\\/(?!user\\/|channel\\/)(embed\\/|(watch)?[?\\/]?v[=\\/]?)?(\\S*)";
final String string = "https://youtu.be/abcdefgh \n"
+ "youtube.com/user/xxxxx youtube.com/channel/xxxxx ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}