$re = '/https?:\/\/((www|m)\.)?(youtube\.com|youtu\.be)\/(?!user\/|channel\/)(embed\/|(watch)?[?\/]?v[=\/]?)?(\S*)/m';
$str = 'https://youtu.be/abcdefgh
youtube.com/user/xxxxx youtube.com/channel/xxxxx ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);