#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\|-{2,}[^-]+-{2,}([^-].*?)(?=\|)"
Local $sString = "|---------------------------------------------Title1(a)---------------------------------------------Content goes here, the quick brown fox jumps over the lazy dog|---------------------------------------------Title1(b)----------------------------------------------Content goes here, the quick brown fox jumps over the lazy dog|" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")