$re = '/\|-{2,}[^-]+-{2,}([^-].*?)(?=\|)/m';
$str = '|---------------------------------------------Title1(a)---------------------------------------------Content goes here, the quick brown fox jumps over the lazy dog|---------------------------------------------Title1(b)----------------------------------------------Content goes here, the quick brown fox jumps over the lazy dog|
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);