const regex = /-[^-]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-[^-]*$', 'gm')
const str = `branch:resource-fix-c95e12f`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);