use strict;
my $str = 'branch:resource-fix-c95e12f';
my $regex = qr/-[^-]*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";