$re = '/-(?!(?:Jan|Feb|Mar|Apr|May|Ju[nl]|Aug|Sep|Oct|Nov|Dec)$).*/m';
$str = ' ID GB_ACC Symbol
1 ILMN_1655796 XM_001127871.1 3-Mar
2 ILMN_1656409 NM_172311.1 STON1-GTF2A1L
3 ILMN_1659893 NM_017418.1 1-Dec
4 ILMN_1662905 NM_001018136.1 NME1-NME2
5 ILMN_1669592 NM_001005416.1 12-Mar
6 ILMN_1670188 NM_172089.2 TNFSF12-TNFSF13
7 ILMN_1677318 NM_001002266.1 8-Mar
8 ILMN_1677446 NM_199203.1 TMEM189-UBE2V1
9 ILMN_1681101 NM_017923.2 10-Sep
10 ILMN_1683974 NM_001003819.1 TRIM6-TRIM34
11 ILMN_1693430 NM_001018136.1 NME1-NME2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);