import re
regex = re.compile(r"-(?!(?:Jan|Feb|Mar|Apr|May|Ju[nl]|Aug|Sep|Oct|Nov|Dec)$).*", flags=re.MULTILINE)
test_str = (" ID GB_ACC Symbol\n"
"1 ILMN_1655796 XM_001127871.1 3-Mar\n"
"2 ILMN_1656409 NM_172311.1 STON1-GTF2A1L\n"
"3 ILMN_1659893 NM_017418.1 1-Dec\n"
"4 ILMN_1662905 NM_001018136.1 NME1-NME2\n"
"5 ILMN_1669592 NM_001005416.1 12-Mar\n"
"6 ILMN_1670188 NM_172089.2 TNFSF12-TNFSF13\n"
"7 ILMN_1677318 NM_001002266.1 8-Mar\n"
"8 ILMN_1677446 NM_199203.1 TMEM189-UBE2V1\n"
"9 ILMN_1681101 NM_017923.2 10-Sep\n"
"10 ILMN_1683974 NM_001003819.1 TRIM6-TRIM34\n"
"11 ILMN_1693430 NM_001018136.1 NME1-NME2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")