$re = '/(?<=[\s,.])\'.*?\'(?=[\s,.])/m';
$str = 'John went out for a walk. He met Mrs. Edwards and said, \'Hello Mam how are you doing today?\'. She replied \'I\'m fine. How are you?\' ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);