#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([abc])(?:[abc]*\1)?$"
Local $sString = "abc" & @CRLF & _
"cac" & @CRLF & _
"aa" & @CRLF & _
"baab" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"c" & @CRLF & _
"cba" & @CRLF & _
"ac" & @CRLF & _
"bb" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")