$re = '/^([abc])(?:[abc]*\1)?$/m';
$str = 'abc
cac
aa
baab
a
b
c
cba
ac
bb
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);