#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?<display>[^<>\n]+)<)?(?<local>(?:[^\n \x22,\.:;<>@\[\\\]]{1,64}|[^\n \x22,.:;<>@\[\\\]]{1,32}\.[^\n \x22,.:;<>@\[\\\]]{1,32}|\x22[^\n]{1,62}\x22))@(?<domain>[\w.]+(?:\.\w{1,4})?|\[(?:IPv6)?[\da-fA-F.:]+\])>?"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"VALID" & @CRLF & _
"Ihavea(comment)tosay@thisistrue.com" & @CRLF & _
"John doe<john@doe.com>" & @CRLF & _
"simple@example.com" & @CRLF & _
"very.common@example.com" & @CRLF & _
"FirstName.LastName@EasierReading.org" & @CRLF & _
"x@example.com" & @CRLF & _
"long.email-address-with-hyphens@and.subdomains.example.com" & @CRLF & _
"user.name+tag+sorting@example.com" & @CRLF & _
"user.name@example.com" & @CRLF & _
"name/surname@example.com" & @CRLF & _
"admin@example" & @CRLF & _
"example@s.example" & @CRLF & _
"" "@example.org" & @CRLF & _
""john..doe"@example.org" & @CRLF & _
"mailhost!username@example.org" & @CRLF & _
""very.(),:;<>[]\".VERY.\"very@\\ \"very\".unusual"@strange.example.com" & @CRLF & _
"user%example.com@example.org" & @CRLF & _
"user-@example.org" & @CRLF & _
"postmaster@[123.123.123.123]" & @CRLF & _
"postmaster@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334]" & @CRLF & _
"_test@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334]" & @CRLF & _
"" & @CRLF & _
"I❤️CHOCOLATE@example.com" & @CRLF & _
"" & @CRLF & _
"INVALID" & @CRLF & _
".hey@boss.com" & @CRLF & _
"yo.hi.hello@man." & @CRLF & _
"abc.example.com" & @CRLF & _
"john..doe@hi.com" & @CRLF & _
"a@b@c@example.com" & @CRLF & _
"a"b(c)d,e:f;g<h>i[j\k]l@example.com" & @CRLF & _
"just"not"right@example.com" & @CRLF & _
"this is"not\allowed@example.com" & @CRLF & _
"this\ still\"not\\allowed@example.com" & @CRLF & _
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com" & @CRLF & _
"i.like.underscores@but_they_are_not_allowed_in_this_part"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")