import Foundation
let pattern = #"(?:(?<display>[^<>\n]+)<)?(?<local>(?:[^\n \x22,\.:;<>@\[\\\]]{1,64}|[^\n \x22,.:;<>@\[\\\]]{1,32}\.[^\n \x22,.:;<>@\[\\\]]{1,32}|\x22[^\n]{1,62}\x22))@(?<domain>[\w.]+(?:\.\w{1,4})?|\[(?:IPv6)?[\da-fA-F.:]+\])>?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VALID
Ihavea(comment)tosay@thisistrue.com
John doe<john@doe.com>
simple@example.com
very.common@example.com
FirstName.LastName@EasierReading.org
x@example.com
long.email-address-with-hyphens@and.subdomains.example.com
user.name+tag+sorting@example.com
user.name@example.com
name/surname@example.com
admin@example
example@s.example
" "@example.org
"john..doe"@example.org
mailhost!username@example.org
"very.(),:;<>[]\".VERY.\"very@\\ \"very\".unusual"@strange.example.com
user%example.com@example.org
user-@example.org
postmaster@[123.123.123.123]
postmaster@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334]
_test@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334]
I❤️CHOCOLATE@example.com
INVALID
.hey@boss.com
yo.hi.hello@man.
abc.example.com
john..doe@hi.com
a@b@c@example.com
a"b(c)d,e:f;g<h>i[j\k]l@example.com
just"not"right@example.com
this is"not\allowed@example.com
this\ still\"not\\allowed@example.com
1234567890123456789012345678901234567890123456789012345678901234+x@example.com
i.like.underscores@but_they_are_not_allowed_in_this_part
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)