package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\:\/\/(?:www.)?([^\/]+)(\/.+")`)
var str = `<a href="https://nova.rambler.ru/search?query=Наталия%20Михайловна%20Дудинская&utm_source=search&utm_medium=enser&utm_campaign=self_promo&utm_content=search">
<a href="https://search.rambler.su/static/search/2852365218/css/main.min.css">
<a href="https://static.rambler.ru">
<a href="https://mail.rambler.ru/?utm_source=search&utm_campaign=self_promo&utm_medium=topline&utm_content=mail">
<a href="//ssp.rambler.ru/capirs_async.js">
<a href="https://vk.com/ekalashnikov81">
<a href="https://vk.com/ekalashnikov81/">
<a href="/saved?lang=ru&fmode=inject&tm=1567237779&tld=ru&la=1566641408&text=Kalashnikov%2CEvgenii&url=https%3A%2F%2Fvk.com%2Fekalashnikov81&l10n=ru&mime=html&sign=287b46925db7ebc34c2171935fd60ead&keyno=0">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}