// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m).*\:\/\/(?:www.)?([^\/]+)(\/.+")"#).unwrap();
let string = "<a href=\"https://nova.rambler.ru/search?query=Наталия%20Михайловна%20Дудинская&utm_source=search&utm_medium=enser&utm_campaign=self_promo&utm_content=search\">
<a href=\"https://search.rambler.su/static/search/2852365218/css/main.min.css\">
<a href=\"https://static.rambler.ru\">
<a href=\"https://mail.rambler.ru/?utm_source=search&utm_campaign=self_promo&utm_medium=topline&utm_content=mail\">
<a href=\"//ssp.rambler.ru/capirs_async.js\">
<a href=\"https://vk.com/ekalashnikov81\">
<a href=\"https://vk.com/ekalashnikov81/\">
<a href=\"/saved?lang=ru&fmode=inject&tm=1567237779&tld=ru&la=1566641408&text=Kalashnikov%2CEvgenii&url=https%3A%2F%2Fvk.com%2Fekalashnikov81&l10n=ru&mime=html&sign=287b46925db7ebc34c2171935fd60ead&keyno=0\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}