#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\d+[a-z]+(?:-\d+[a-z]+)*$)(?>(?<gal>\d+)gal-?)?(?>(?<qt>\d)+qt-?)?(?>(?<pt>\d+)pt-?)?(?>(?<cup>\d+)cup-?)?(?>(?<oz>\d+)oz-?)?$"
Local $sString = "1gal" & @CRLF & _
"1qt-2cup" & @CRLF & _
"1gal-6oz" & @CRLF & _
"1gal" & @CRLF & _
"6oz" & @CRLF & _
"1gal-1qt-2pt-2cup-5oz" & @CRLF & _
"1gal-1qt-2oz" & @CRLF & _
"" & @CRLF & _
"1gal-1qt-2pt-2cup-5o" & @CRLF & _
"1gal-1qt-2oz-2cup" & @CRLF & _
"1gal-1qt-2oz-2cup" & @CRLF & _
"-1gal-1qt-2oz" & @CRLF & _
"1gal-1qt-2oz-" & @CRLF & _
"" & @CRLF & _
"sfgsdfgdsfaf" & @CRLF & _
"1gal-3qt-5a" & @CRLF & _
"1qt2cup" & @CRLF & _
"1gal2qt-3pt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")