using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\d+[a-z]+(?:-\d+[a-z]+)*$)(?>(?<gal>\d+)gal-?)?(?>(?<qt>\d)+qt-?)?(?>(?<pt>\d+)pt-?)?(?>(?<cup>\d+)cup-?)?(?>(?<oz>\d+)oz-?)?$";
string input = @"1gal
1qt-2cup
1gal-6oz
1gal
6oz
1gal-1qt-2pt-2cup-5oz
1gal-1qt-2oz
1gal-1qt-2pt-2cup-5o
1gal-1qt-2oz-2cup
1gal-1qt-2oz-2cup
-1gal-1qt-2oz
1gal-1qt-2oz-
sfgsdfgdsfaf
1gal-3qt-5a
1qt2cup
1gal2qt-3pt
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}