re = /.*?from\s(\S+).*/m
str = 'delete from pear.admin where jdjdj
delete from pear.admin_user where blah
delete from ss_pear.admin_user where blah '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end