$re = '/Let\'s start(.*[\r\n])*.*my friend\./m';
$str = 'Let\'s start! ... blah, blah, blah...
How much longer? It\'s joe\'s place, isn\'t it?
This is the end, my friend.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);